スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

この間の続き、いえいえ間ですよ

前回、間とい命令をやりましたが、もう少し突っ込んで見ましょう。

条件のところを変えて見ましょう。

条件の間であれば、繰り返されます。条件とは、間の前のことです。

今日はポイントが3点あり、それが0になったら終わるプログラムを作ってみましょう。

ポイント=3

「ポイントは3点です。」と表示

(ポイント>0)の間
	
	「問題1:1+1は2である?」と二択
	もし、それがいいえならば、ポイント=ポイント-1
	
	ポイントを表示
	
	「問題2:2-1は1である?」と二択
	もし、それがいいえならば、ポイント=ポイント-1
		
	ポイントを表示
	
	「問題3:2×1は2である?」と二択
	もし、それがいいえならば、ポイント=ポイント-1
		
	ポイントを表示
	
「ポイントがなくなりました。」と表示

間-ポイント

これを実行すると、一応目的の物に近いものになります。

ただこれを実行してみるととあることに気付きます。それは、どうやら、ループされる際に、ポイントが0でない時に、繰り返されますが、0以下になっても命令は続くようです。

というのは、ループされる際、最後のポイントが1以上であれば、次の3問を続けられるようです。-2とかになるので、多分そうなんだと思いますが。

間-ポイント結果

きっちり0で終わらせたいなとしたらどうしたらいいのか?

少し内容を変えてみました。

ポイント=3

「ポイントは3点です。」と表示

(ポイント>0)の間
	
	「問題1:1+1は2である?」と二択
	もし、それがいいえならば、ポイント=ポイント-1
	
	ポイントを表示
	
	「問題2:2-1は1である?」と二択
	もし、それがいいえならば、ポイント=ポイント-1
		ポイント<0なら終わる
		
	ポイントを表示
	
	「問題3:2×1は2である?」と二択
	もし、それがいいえならば、ポイント=ポイント-1
		ポイント<0なら終わる
		
	ポイントを表示
	
「ポイントがなくなりました。」と表示

間-ポイント改良版1

これだと思っていたものに近くなりました。

感でやってみるものですね。

もう少し変化を加えて見ましょうか。

theme : プログラミング
genre : コンピュータ

tag : なでしこ 繰り返し

comment

Secret

なでしこ
プロフィール

なでしこ初心者

Author:なでしこ初心者
FC2ブログへようこそ!

最新記事
最新コメント
最新トラックバック
月別アーカイブ
カテゴリ
検索フォーム
RSSリンクの表示
リンク
ブロとも申請フォーム

この人とブロともになる

QRコード
QRコード
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。