スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

前回の間命令を改造してみた

前回やったなでしこの間命令を少し改造してみました。

今回はプログラムだけ書いておきますね、結果は試してみてください。

ポイント=3

「ポイントは3点です。」と表示

(ポイント>0)の間
	
	「問題1:1+1は2である?」と二択
	もし、それがはいならば、「正解!」と言う
		ポイントは、ポイント+1
	 
	違えば、「違います!」と言う
		ポイント=ポイント-1
	
	ポイントを表示
	
	「問題2:2-1は1である?」と二択
	もし、それがはいならば、「正解!」と言う
		ポイントは、ポイント+1
	 
	違えば、「違います!」と言う
		ポイント=ポイント-1
		
		ポイント<0ならば、「ポイントがなくなりました。」と言う。
		ポイント<0ならば、終わる
		
	ポイントを表示	
	
	「問題3:2×1は2である?」と二択
	もし、それがはいならば、「正解!」と言う
		ポイントは、ポイント+1
	 
	違えば、「違います!」と言う
		ポイント=ポイント-1
		
		ポイント<0ならば、「ポイントがなくなりました。」と言う。
		ポイント<0ならば、終わる

	ポイントを表示	
	
「ポイントがなくなりました。」と表示

いろいろ変えて遊んでみてください。なにか新しい発見があるかもしれませんからね。

theme : プログラミング
genre : コンピュータ

tag : なでしこ

comment

Secret

なでしこ
プロフィール

なでしこ初心者

Author:なでしこ初心者
FC2ブログへようこそ!

最新記事
最新コメント
最新トラックバック
月別アーカイブ
カテゴリ
検索フォーム
RSSリンクの表示
リンク
ブロとも申請フォーム

この人とブロともになる

QRコード
QRコード
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。